Gentoo Logo

OpenConnect: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-18 / openconnect
Release Date May 18, 2014
Latest Revision May 18, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/openconnect < 4.08 >= 4.08 All supported architectures

Related bugreports: #457068

Synopsis

A buffer overflow in OpenConnect could result in execution of arbitrary code or Denial of Service.

2.  Impact Information

Background

OpenConnect is a free client for Cisco AnyConnect SSL VPN software.

Description

A stack-based buffer overflow error has been discovered in OpenConnect.

Impact

A remote attacker could entice a user to connect to a malicious VPN server, possibly resulting in execution of arbitrary code with the privileges of the process, or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenConnect users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/openconnect-4.08"

4.  References



Print

Page updated May 18, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.