Gentoo Logo

Pidgin: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-22 / pidgin
Release Date May 18, 2014
Latest Revision May 18, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-im/pidgin < 2.10.9 >= 2.10.9, revision >= 2.10.9-r1 All supported architectures

Related bugreports: #457580, #499596


Multiple vulnerabilities in Pidgin may allow execution of arbitrary code.

2.  Impact Information


Pidgin is a GTK Instant Messenger client for a variety of instant messaging protocols.


Multiple vulnerabilities have been discovered in Pidgin. Please review the CVE identifiers referenced below for details.


A remote attacker could possibly execute arbitrary code with the privileges of the Pidgin process, cause a Denial of Service condition, overwrite files, or spoof traffic.

3.  Resolution Information


There is no known workaround at this time.


All Pidgin users on HPPA or users of GNOME 3.8 and later on AMD64 or X86 should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-im/pidgin-2.10.9-r1"

All Pidgin users on ALPHA, PPC, PPC64, SPARC, and users of GNOME before 3.8 on AMD64 and X86 should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-im/pidgin-2.10.9"

4.  References


Page updated May 18, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.