Gentoo Logo

Symfony: Information disclosure

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-25 / symfony
Release Date May 18, 2014
Latest Revision May 18, 2014: 1
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-php/symfony < 1.4.20 All supported architectures

Related bugreports: #444696

Synopsis

A vulnerability in Symfony may allow remote attackers to read arbitrary files.

2.  Impact Information

Background

Symfony is a professional, open-source PHP5 web development framework.

Description

Symfony does not properly sanitize input for upload requests.

Impact

A remote attacker could send a specially crafted file upload request, possibly resulting in disclosure of sensitive information.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

Gentoo has discontinued support for Symfony. We recommend that users unmerge Symfony:

Code Listing 3.1: Resolution

  # emerge --unmerge "dev-php/symfony"

4.  References



Print

Page updated May 18, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.