Gentoo Logo

GnuTLS: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-09 / gnutls
Release Date June 13, 2014
Latest Revision June 13, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-libs/gnutls < 2.12.23-r6 >= 2.12.23-r6 All supported architectures

Related bugreports: #501282, #503394, #511840

Synopsis

Multiple vulnerabilities have been discovered in GnuTLS, the worst of which could lead to arbitrary code execution.

2.  Impact Information

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could utilize multiple vectors to spoof arbitrary SSL servers via a crafted certificate, execute arbitrary code or cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r6"

4.  References



Print

Page updated June 13, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.