Gentoo Logo

FreeRADIUS: Arbitrary code execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-12 / freeradius
Release Date June 15, 2014
Latest Revision June 15, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-dialup/freeradius < 2.2.5 >= 2.2.5 All supported architectures

Related bugreports: #501754

Synopsis

A vulnerability in FreeRADIUS can lead to arbitrary code execution or Denial of Service by authenticated users.

2.  Impact Information

Background

FreeRADIUS is an open source RADIUS authentication server.

Description

Large passwords can trigger a stack-based buffer overflow in FreeRADIUS’s rlm_pap module when authenticating against an LDAP server.

Impact

An authenticated user could set a specially crafted long password, possibly leading to arbitrary code execution or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All FreeRADIUS users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-dialup/freeradius-2.2.5"

4.  References



Print

Page updated June 15, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.