Gentoo Logo

KDE Libraries: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-34 / kdelibs
Release Date June 29, 2014
Latest Revision June 29, 2014: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
kde-base/kdelibs < 4.12.5-r1 >= 4.12.5-r1 All supported architectures

Related bugreports: #358025, #384227, #469140, #513726

Synopsis

Multiple vulnerabilities have been discovered in KDE Libraries, the worst of which could lead to man-in-the-middle attacks.

2.  Impact Information

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like operating systems. KDE Libraries contains libraries needed by all KDE applications.

Description

Multiple vulnerabilities have been discovered in KDE Libraries. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could cause a man-in-the-middle attack via any certificate issued by a legitimate certification authority. Furthermore, a local attacker may gain knowledge of user passwords through an information leak.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All KDE users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-4.12.5-r1"

4.  References



Print

Page updated June 29, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.