Gentoo Logo

OpenSSL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201407-05 / openssl
Release Date July 27, 2014
Latest Revision July 27, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/openssl < 1.0.1h-r1 >= 1.0.1h-r1, revision >= 1.0.0m, revision >= 0.9.8z_p1, revision >= 0.9.8z_p2, revision >= 0.9.8z_p3, revision >= 0.9.8z_p4, revision >= 0.9.8z_p5 All supported architectures

Related bugreports: #512506

Synopsis

Multiple vulnerabilities have been found in OpenSSL, possibly allowing remote attackers to execute arbitrary code.

2.  Impact Information

Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general purpose cryptography library.

Description

Multiple vulnerabilities have been discovered in OpenSSL. Please review the OpenSSL Security Advisory [05 Jun 2014] and the CVE identifiers referenced below for details.

Impact

A remote attacker could send specially crafted DTLS fragments to an OpenSSL DTLS client or server to possibly execute arbitrary code with the privileges of the process using OpenSSL.

Furthermore, an attacker could force the use of weak keying material in OpenSSL SSL/TLS clients and servers, inject data across sessions, or cause a Denial of Service via various vectors.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1h-r1"

4.  References



Print

Page updated July 27, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.