Gentoo Logo

libpng: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201408-06 / libpng
Release Date August 14, 2014
Latest Revision August 14, 2014: 2
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libpng < 1.6.10 >= 1.6.10, < 1.3, revision >= 1.5.18 All supported architectures

Related bugreports: #503014, #507378


Multiple vulnerabilities have been discovered in libpng which can allow a remote attacker to cause a Denial of Service condition.

2.  Impact Information


libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several programs, including web browsers and potentially server processes.


The png_push_read_chunk function in pngpread.c in the progressive decoder enters an infinite loop, when it encounters a zero-length IDAT chunk. In addition certain integer overflows have been detected and corrected.

The 1.2 branch is not affected by these vulnerabilities.


A remote attacker could entice a user to open a specially crafted PNG file using an application linked against libpng, possibly resulting in Denial of Service.

3.  Resolution Information


There is no known workaround at this time.


All libpng users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.6.10"

Users with current installs in the 1.5 branch should also upgrade this using:

Code Listing 3.2: Resolution

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.18:1.5"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying these packages.

4.  References


Page updated August 14, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.